Windows Done Did Blow Up!

Another day of complete and total hardware failure :(  The plan was simple… help clean up the office by converting two computers into one by moving my aging linux desktop (mostly unused except for the occasional consulting project I get) into a virtual machine (using either Virtual Box or VMWare) on my more modern (but still 4 years old) Windows system.  Seems simple enough right?

First thing is that the windows box is only 32 bit, and that means I lose a chunk of the 4G of RAM I have in there.  So my plan went something like this:

  • Upgrade windows 7 to 64bit
  • Copy across settings, re-install programs
  • Create virtual machine for linux
  • Copy across settings, re-install programs
  • Decomission old linux machine

First step was to install Windows 7 64bit on my windows machine. I have a spare hard drive, so I disconnected everything else and started at it.  And it was slooooooow…..  Getting to the first screen took 5 minutes, the second 10, and when I finally did get to the installing part it was going at about 1% every 5 minutes. 

A bunch of reading suggested things like disabling floppy drives in the bios, disabling USB, etc, all of which were tried to no avail.  After about five hours of this I was getting near madness.  Mostly because I’d let it start going, it’d be horribly slow, and I’d say to myself “just let it go, it’ll take forever but it’ll be done”, then 20 minutes later I’d get in a rage that I should have to endure such sillyness and reboot and try another method of making it go fast that I’d found.  Finally I found that pulling 2 of the 4 G of ram out made it suddenly, magically work at full speed.

So now Windows 64bit is installed, booted, and ready to have me set things up.  So I shut it all down, put the RAM back in, re-connected the hard drives (I’d need access to my old hard drives to copy settings across of course), and booted it back up.

Except it didn’t boot up.  The power light on the motherboard went on, but no fans started, no hard drives whirred to life, and my “powerful” (as of 4 years ago) system seemed dead as a doornail.  Still is in fact.  I’ve run through about every troubleshooting scenario I can think of, disconnecting everything, re-plugging everything in, and outside of replacing the power supply (I’ll be grabbing one of those later this morning as all of the “spare” ones I have are old and ancient), my only conclusion is that the motherboard decided to fry itself.

Sucky for multiple reasons.  I do enough photography stuff that I need the “big” computer and the laptop won’t do.  So I want to hold off on replacing it completely with a decked out 27″ iMac full of RAM and hard drive space in a nice shiny box (a very expensive shiny box that is), and I don’t wnat to replace it with a “London Drugs Special” system that’ll kinda do what I want, but be still kinda sucky, and I really hate doing what I’m continuing to do which is upgrade bit by bit and have a box stuffed full of parts.  Bleah.  Fingers crossed that replacing the power supply will work anyway, and the damage will be only about $100 :(

Read More

Upgraded My Laptop

After spending a while hitting the limit of my laptop hard drive, and being annoyed with being forced to actually cull my data and videos and music to make it all fit, I finally realized that for under $100 I could almost triple the storage space I had in it with little or no worries (other than possibly voiding the warranty, not an issue in a 2.5 year old machine).   It was actually pretty easy to do, other than one or two minor blips.  There’s lots of information online about how to do it, and other than the minor detail of needing a computer to read the instructions on while you have the computer open with it’s guts exposed, it was up and done with no muss and no fuss.

Hard Drive Cloning

First things first, reading resources. 

  • This Extreme Tech article is great, and being the first hit on google was nice.
  • When I did run into one thing I needed confirmation on, this video showed that there were minor differences in the versions of the hardware (or at least from the first article).

So for $79 I picked up a 500G, 7200rpm laptop drive, and a few dollars more I got the SATA to USB connector kit that would let me connect the drive to the computer as a USB drive.  This was needed to make the upgrade smooth. Oh, and a T-6 Torx screwdriver as well, as per the article.  Seems apple can’t leave it at just one type of screw in their bodies….

CCC Done

When I got home I made sure my homebrew time capsule backup was current, and nuked a few un-needed big files from the desktop.  I assembled the SATA drive and adapter and plugged in the drive, formatted it, and then I broke out Carbon Copy Cloner.  CCC is an awesome utility that basically will clone one drive to another and make it bootable if needed, so for me the theory was clone old drive to new drive, swap out drives, boot up on new drive, with all my data in place and no issues.  In theory.

Unlike most stories about me and hardware, this time the theory was the reality.  I assembled a bit of paper to keep track of which screws went where, consulted the webpages a lot for each step, got a little scared with the sticky cable attached to the top of the drive, and in the end, reversed the whole process to put it all back together.

DisassemblyEnd result, computer working properly, more than twice the disk space, and only about $100 spent on tools, adapters, and the actual drive.  Well worth saving the random “dangnabbit what else to I have to delete now!?” yells.

Read More

Hardware Issues… Error In Operator

Yea, so after 12+ hours of cursing screaming and cursing the name of Microsoft, Bill Gates, and Steve Ballmer… yea, as I was running out of the house this morning I remember that to try to get the SATA drives recognized by Spinrite I switched the SATA access mode from AHCI to IDE in the computer’s BIOS, rebooted and voila, Windows boots up just fine. Ooops.

As an extra bonus, my Drobo seems to be talking to the world again just fine. I’ll plug it directly into my Mac when I get home tonight to run a disk check on it again to be sure, but I think maybe just having it’s bits twiddled by the various disk utility software got it back up and going properly.

Sometimes as I’m finding, the problem is just me….

Read More

More Ironic Hardware Failures

So I spent all weekend running seagate and spinrite diagnostics on the drives in my Drobo, because it’s been doing odd things (again) lately and I’m wondering if it’s bi-polar “I have your files / no I don’t / yes I do / no I certainly don’t” nature is caused not by a failure in the Drobo firmware or a constantly corrupting partition table, but instead something more simple like a bad disk that the Drobo just hasn’t detected.

So after running the 4-5 hour test on each disk (and then some) and finding nothing wrong, I finally figured maybe it’s just me and I’ll reformat it and re-partition it. So I put all the disks back in the box and boot it back up (irony alert: now everything is there just dandy). Then I put my desktop computer back together (it was needed to attach the disks to it to run the utilities) and boot it backup. It boots to the Windows logo, and reboots. Reboots to the Windows logo and reboots. Reboots to the.. well, you get the picture.

Luckily the second time it reboots it gives me the option to go into the repair console, which is where it is now, with a little progress bar going slowly and sadly back and forth across the screen “searching for problems”.

I actually ran it once already and I got tired and thought maybe I’ll just try rebooting it and nope, that didn’t work. So I’m back here, hoping that I don’t have to run a disk utility on my desktop machine, which, before being opened to run disk checks on other disks, was running absolutely fine.

Some days I really want to just toss all this stuff in the trash and start over.

Hopefully soon it’ll come back and tell me that it’s found something wrong, fixed it, and I can now reboot back to my computer again.

Read More

My Drobo Just Lost All My Data (Updated: It’s alive!)

So this morning I woke up and my first generation Drobo was acting funny. I rebooted it, and long story short when it came back it looks like the first 2TB partition, where all my data was stored, was gone, currupted, nuked, or otherwise unavailable. All my music, tagged over a period of months. All my videos, collected over years, and my collection of “classics” I’ve been making sure I get so that they are safe. All 13 seasons of Top Gear. All 40+ years of Doctor Who. All. Gone.

I’ve emailed off to Data Robotics, and I will gladly pay them the $100 (or hell, $500) support license I decided not to renew last year (because of course everything was going fine) if they can magically get it back for me.

Of course, if it does come back, will I now be able to trust the device? Or will I have to build a new system with another wack of disk space to act as a backup for that (blah blah best practices of course blah blah)? Or should I just dump the $1000+ worth of computer hardware and build another Linux box with RAID5 or buy a Windows Home Server box that does similar things.

I hate computers. Especially now as the Drobo was something that was rock solid and had had zero issues in the time I’ve had it. Data Robitics, or Cali Lewis, help me, you’re my only hope!

Seriously, this is completely bummed me out.

Update: After a few back and forths with Valorie at Data Robitics, and the end result of this being “just run the disk utillity”, plus running a couple of other mac data recovery bits, the Drobo seems to have righted itself somehow. It told me first it couldn’t recover anything, but after a bit more mucking around I suddenly noticed a “Storage1” (the name of the partition) sitting on my desktop. Drilling into it I could see my data, and drilling down farther I could (wait for it!) access my data!

Yay!

So now I’m frantically backing up, though I’m not sure if this really needs a backup or not. I’m also going to be picking up a 1 or 2 TB secondary backup tomorrow to have a backup for my backup, just in case. However, my data, my precious data appears (so far) be be alive. The backup is going to take about 5 hours it says, so we’ll see if it makes it through that without incident.

Yay!

Read More

A Week-Long Feeling Couple of Days of Personal Fail


OK, long, sad story coming up. Bail out now if you need to. Dad called saying his computer was doing strange things, not booting right (starting up a linux boot screen), messages about a drive failing, etc.
Oh, and Dad, this is not a reflection of you asking me to help you with your computer, but my own personal failings and reasons that I have started to wonder how I can put my socks on in the morning by myself. Since you don’t have a computer right now you won’t be seeing this until after I’ve explained in person the problems I had with it.
Anyway, you’d figure any moron with 15+ years dealing with computers and PC hardware could deal with the issues, right? Throw in a disk checker (such as SpinRite), use something to clone the bad disk to a new one, do some cleanup, upgrade everything, install all the patches and updates, done in an evening right? Heck, I even had an older USB hard drive that, when taken apart, yielded a nice 230G PATA drive to use (and being the computer is 5+ years old, with C: being a whopping 13G drive, even this small-by-today’s-standards drive would be a huge improvement). Even better I even had a better (not by much) video card to put in.
So I started…. here’s a list of what went wrong to start with.


  • Spent lots of time mucking around and cloning the wrong drive. Cloned C: to the new drive instead of E: (clearly written on the paper that I got) which was the one that was failing.
  • Spent lots of time plugging drives in and out figuring out which was which and what names windows (XP) would give the drives if they were plugged in and out.
  • Finally decided to just get rid of the E: all together, re-install / move the data on E: (which was where program files were being moved to as the 13G C: was 90% full), and leave F: (digital photo storage) alone (other than re-partitioning it, as it was a 40G drive with 10G of NTFS available and the rest old linux partitions!).
  • At some point a wayward IDE cable made it’s way into the CPU fan unnoticed, and the system ran for a while with no CPU fan, until it slowly crashed and (almost) burned. Left it overnight at this point to let everything cool off nicely to stop the warbling motherboard alarm from going off and telling me the CPU was slowly sizzling itself to death.

Ok, finally got things all figured out, booting up on the new 230G drive, yay! Now the long and horrible task of updating everything to SP3 + patches + patches for patches + extra software + patches for extra software. New video card went in so it needed new drivers, I had to re-install some software to make sure that the now-not-there E: location was updated properly, etc. All time consuming in the waiting, but fairly standard.
Almost all done, just need to swap the new drive in and done!
Now up until now the computer had been sitting sideways on the floor, with all the old drives still in it (just in case I needed to remember where one was plugged in or something) and the new one sitting on top.
You other geeks can see what’s coming can’t you? Yea….
I moved the new drive just a tiny bit on the top of the case and heard a tiny little “pop” and that smell that no computer person wants to smell, the smell of the magic smoke escaping.
Nooooooooooooooooooooooooooooooooooo!!!!!!!!!!
Now this was mid-day today, after 2 (calendar) days of working on this.
And there was no luck for me here, no drive magically working afterward, it was dead, dead, dead. Completely setup, updated, patched, and not-recognizable by the BIOS at all. My wife can attest that I had none-too-kind words for myself after that.
Did I mention that yesterday I was out at the lake with some friends and got myself nicely sunburnt? Not even a nice all over burn, instead it’s all blotchy. Bleah. And hurts.
OK, back to the computer. What to do. OK, start over again.

  • I found another older USB hard drive, only 160G but still usable. Nope, won’t boot, dead and old. Pitch into the garbage.
  • Last shot was a nice 500G external that I have (sorry Brian). Complete overkill for Dad, but it’ll work.
  • Repeat the same steps. Clone the drive to start.
  • Clone done, swap cables…. drive starts to boot to windows and reboots. WTF? OK, maybe 500G is too much for the BIOS to handle. Re-jigger some things and try the clone again, oh, and there it goes again working. Odd (more on this later).
  • Reboot, ensure it’s booting the right drive, backup the bad drive to it, do the Windows Update and Patch Dancetm. Software moving, re-installing, re-updating, etc.

Now it’s almost midnight tonight, everything is tested and rebooted to make sure things come up properly, and it’s ready for the final re-jigger of the hard drives (I’ve been using a magazine to keep the drive off the metal case to be safe).
OK, so the motherboard was one of the first ones with ATA100 PATA ports, and it actually had 4 IDE ports on it, 2 “standard” ones and 2 that show up to a secondary SCSI BIOS. For best performance I figure C: is master on the first ATA100, the pictures drive is master on the second ATA100, and the DVD drive is primary master on the “standard” IDE ports.
Plug it all in and boot up. Computer goes “beee woooo beee woooo”. Hmm…. not good. Unplug DVD drive, computer starts booting. Weird. OK, lets boot up without the DVD in at all. Boots, windows boot screen comes up, aaaaaannnnnnd……. reboots.
Again with the screaming at the sky.
Nooooooooooooooooooooooooooooooooooo!!!!!!!!!!
Another hour or so of fucking around with it it looks like something either in the form of a drive incompatibility or maybe the magic smoke got let out of the the SCSI controller. Re-do the drives so they’re all on the “standard” IDE ports, reboot (pray), see it working, shut down, reboot again to make 100% sure, it boots, and shut it down and get it ready to go back to it’s home tomorrow.
Yay.
Then of course there’s my other buddy’s computer that he wanted re-installed, so that was started next.
All’s well that ends well at 2am on a Friday :)

Read More

Buy My Stuff! Computer Sale!

In an effort to clean out the basement, I’m selling off a bunch of the hardware I’ve accumulated over the years, or taking it to the dump or computer recycling place. If you’re in the Fraser Valley and are looking for any of the following, email me at alan@ufies.org to let me know. Links go to the craigslist posts I’ve made which have links, prices and pictures.

There are lots of other things, old hard drives in the 2/4/40gb range, USB cables, tons of PATA hard drive cables, etc.

Read More

My First Apple Tech Support Experience

Conclusion: 8.5/10

I got into work today, plugged in my MacBook Pro to power, USB keyboard/mouse, network cable, and secondary display…. wait a minute, second display is still in power saving mode, that’s odd.

OK, reboot. Nothing. Unplug, replug. Nothing. Troubleshoot by checking to see if the monitor works with another computer (it does), if the computer can output to a different DVI monitor (it could), and if a different DVI-to-VGA dongle worked (it didn’t).

Bleah. I guess this is why $work got the AppleCare plan for me though, so I called up the number….

First of all, up to the part when you get on hold was great. There was none of the horrible voice-recognition systems that I’ve learned to despise and there were only three buttons to hit to get to where I wanted to be (1 for english, 1 for support, and 3 for laptops). However, once I got into the queue and waited for the five or so minutes they predicted the wait time would be, it rang, then I got nothing. After waiting for a couple of minutes with no hold music and no voice on the other end, I rang up and redialed.

The second time through I found that you could hit the number options before the full set of options has completed, bonus points for that. This time after the five minutes listening to elevator music I did actually get to talk to a real person (Stacy, who didn’t sound like she was a call center in Bangladesh or some similar place).

Other than a bit of confusion as I had switched out the monitor that wasn’t working for another monitor that also wasn’t working (she thought that I meant that the old monitor worked and the new one didn’t), and some standard troubleshooting which I had already done, then a couple of minutes more on hold while she consulted co-workers, she got me to do the vulcan neck pinch reboot (command-option power on then hold down P and R while standing on one leg at sunset of a full moon while the eclipse is in the northern hemisphere) to reset the PRAM. Voila, problem solved.

Pros


  • Got the problem fixed (most important thing)
  • Speaker had english as a first language
  • Only 3 buttons to get to wait on hold
  • Can hit buttons before voice finishes speaking
  • No voice recognition software

Cons

  • Was disconnected / frozen randomly on first call
  • Wait time of 5 minutes each time (though these days that’s still pretty low
  • Sucks that the problem happened in the first place!

All in all a pretty good experience

Read More

Odd Hardware Karma (A Tale of Mice and KVMs)

I’m wondering if Darren’s hardware karma has somehow rubbed off a bit on me….

First of all, midway through the day yesterday my mouse scroll partially died. Having no scroll wheel sucks when you are used to it. “OK,” thinks I. “I was thinking about a new mouse anyway, and Firefly will be going by a computer store today anyway, so why not?”. I talked to a guy at work and he suggested the Logitech MX Revolution, the latest in funkyness from Logitech. It was something I looked at a while back but had no reason to get since my mouse was just fine at the time.

And it’s $50 cheaper than at London Drugs of Future Shop.

Fast forward to the evening after work as I unpack it and find that it’s USB only and won’t work with USB -> PS/2 adapters and therefor won’t work with the KVM I have (a nice and simple little two port LinkSys dealie-o). “Drat,” thinks I. “I was thinking about getting into the modern age anyway and getting a full USB KVM anyway, and if I’m upgrading anyway, a four port one would let me do work on another two computers at the same time.”

Run down to London Drugs and find a nice little I/O Gear 4 Port USB KVM. It’s relatively small, and only has two of the four included cables built in, so I don’t have to have (as much of) a rats nest under the desk.

Crap, my keyboard is PS/2 (what sort of a stupid modern keyboard is only PS/2?). And I have no PS/2 -> USB adapters. Ok, run back down to London Drugs and get one. Grr..

OK, so now I can finally plug everything in and it all works! Well, except that Logitech, in their infinite freaking wisdom decided to put computing back 20 years and not included a middle mouse button!!!

Yes, you heard me right. The big fancy scroll wheel (which has a “hyperspeed” scroll mode, where it goes from a normal “click-click-click” scroll to free scroll where it spins – super-extra cool) can be clicked, but only to switch between normal scroll and hyperspeed scroll. The drivers don’t have any options. Also, clicking the wheel is pretty clunky, so I’m not sure it’d work well anyway. There’s another button sitting right behind the scroll wheel which would be perfect for setting as middle mouse click, but no, it’s only choices are “search” and “zoom”.

I looked on the net and found that everyone doing a review of the mouse seems to have noted the lack of middle click, but no one is up in arms. All the reviews are four out of five stars with a quick note about “lack of middle click” in the conclusion. I’d be screaming from the rooftops or heading to Logitech with a petition or something. For me the gaming aspect and computer management relies way to heavily on the middle mouse button to lose it :(

So unless I find out a way of fixing this today, or hear from someone a fix, I’ll be packing it back up and taking it back. Probably get myself a Logitech G7 (gaming mouse) or the MX 1000 (successor to the one MX 500 I have now) instead.

Second bitch I have is that the KVM I got doesn’t follow the standard “scrlk-scrlk” to swap computers. Instead (cause it’s all fancy and stuff I guess) it uses “scrlk-scrlk+<enter>” to swap computers, and a bunch of other “scrlk-scrlk+<key>” commands to do things like swap computers only, or audio only, or computer and usb but not audio, etc. A real PITA if you want to swap computers quickly and are used to just “scrlk-scrlk”. Adding the extra key in there is really unwieldy :(

So I’ll probably also return the KVM for something that is a straight two port USB switch like this (I have no love for I/O gear, I just happen to know that this KVM was in the store) which uses only “scrlk-scrlk” to switch computers.

Read More

Intel DP965LT and Microphone

Not that long ago I got myself a new system based on the Intel DP965LT motherboard. The only thing that I still can’t get going is the microphone. Anyone else have this working with this hardware?

What happens is that basically nothing happens when I plug in the microphone. No output when I yell into it, either plugged into the front audio headers of the case, or the rear. According to the Troubleshooting Audio Issues for the board, I should ensure that the sound recording device is set to Realtek HD Audio. Except that the board comes with no Realtek devices, but has the SigmaTel STAC9227, that’s great.

I have the Intel audio studio installed, along with the latest drivers, but no joy. The board has the audio headers plugged into the standard audio block that comes from the case, though I’ve tried the alternate setup with the slightly re-arranged pins (using the individual pins instead of the preformed block).

I have 5.1 surround headphones, so what I’d like to do is have them plugged into the back three connectors and just plug the microphone into the front audio plugin on the case. I’ve tried this setup as well as the plain old “1 connector for audio, 1 connector for microphone” setup as well.

Anyone seen this? Heck, anyone have the microphone going with this motherboard period?

Read More